Player Resource Consortium

 

Author Topic: PRCModuleUpdater fails to complete patch  (Read 2927 times)

0 Members and 1 Guest are viewing this topic.

February 14, 2021, 08:44:22 AM
  • Adept
  • *
  • Posts: 1
  • Karma: +0/-0
  • New Member
    • View Profile

Hello,

I hope I am not asking about something that has already been answered, but the only relevant posts are about 2-3 years old and mostly stating that the Updater can't find the directory for NWN EE, which from what I see now is not the case (though I do have to manually navigate there).

I have moved all relevant files as instructed in the Documents directory and the modules I've tried to patch are in the install directory. I run the PRCModuleUpdater (have tried running as Admin as well), it decompresses and begins to perform some actions, but it fails at various stages. I have NWN EE installed on 2 different PCs, on both it either fails on "Checking for overwrites"or it manages to proceed to find conflicts and once I continue it proceeds to "Setting module properties for ..." but just ends there without performing any changes. Overall I haven't been able to patch any module, (I initially tried a larger module, but now I'm only trying to get Contest of Champions patched before moving on).

I guess I should point out that I have a somewhat "hacky" installation (the NWN Documents directory is outside of the Documents folder but referred to by junctions), but the Toolset and the game work as they should and the updater lists both .hif files and all modules in the installation directory.
« Last Edit: February 14, 2021, 09:14:00 AM by Belthil »


February 18, 2021, 07:39:50 PM
Reply #1

Drop by the discord and look for Nate E, he's been testing a solution to this issue but hasn't finalized it yet.
That is not dead which can eternal lie.
And with strange aeons even death may die.


July 17, 2021, 09:29:10 PM
Reply #2

Hello, I am having this same issue, and your discord invite link no longer works, so I do not have that option (I am stupid - the one on the main page does not work for me.  The one above the forum does).  Fails at the same place.  NWN Diamond, GoG.  Note that GoG does not seem to give you a Documents folder, so I am installing everything in the main directory.  Various pieces of forum posts advised me to do this.

Solved: https://sourceforge.net/p/daprc/code/HEAD/tree/nwn/nwnprc/trunk/CompiledResources/ from the discord.  I did not use the classic module updater.  Sorry for the necro. 
« Last Edit: July 17, 2021, 09:45:40 PM by annskelerton »